, , ,

Hello Everyone,

Today while installing Dynamics CRM on a new machine, I encounter yet another error which I’m going to discuss about.

During CRM Email Router Setup the following message popped up on my screen:

After I clicked OK on the message window, the following screen mentioned the detailed error:

As per Microsoft : 

  • The Messaging API is a COM-like API that provides access to the contents of messaging stores.
  • CDO 1.2.1 (Collaboration Data Objects, version 1.2.1) is a package providing access to Outlook-compatible objects through a COM-based API.
  • Using either CDO or MAPI, a program can connect to a MAPI store, and then perform operations against that store. Starting with Exchange 2007, Microsoft will distribute the MAPI client libraries and CDO 1.2.1 as a Web download.

Consequently, starting with Exchange 2007, neither the Messaging API (MAPI) client libraries nor CDO 1.2.1 are provided as a part of the base product installation. As a result, there is functionality missing that many applications depend on. Microsoft Exchange MAPI and CDO 1.2.1 provide access to these APIs.

These Missing (MAPI and CDO) can be downloaded from the given link here: MAPI and CDO

Kindly follow my Next Blog in case you face an issue of “MAPI and CDO 1.2.1 cannot be installed with Microsoft Outlook” while installing the downloaded file.

Once the Downloaded files are installed, the Email router setup will be completed without any further issue.

Hope this will help someone figure out the error soon. The same has also been discussed on the Microsoft KB Article.

Thanks !!!